Rapidbike EVO-Check Engine - KTM Duke 390 Forum
 20Likes
Reply
 
LinkBack Thread Tools
post #1 of 44 Old 09-03-2019, 02:04 AM Thread Starter
Senior Member
 
Eddyg22's Avatar
 
Join Date: Jan 2019
Posts: 100
Garage
(Thread Starter)
Rapidbike EVO-Check Engine

Hey, I have been riding with my rapid bike ecu installed for about 200 miles now and I just received a check engine light today. Bike has been running great though. Anyone else run into this? Any way to reset it or check it. I feel like the shop will charge me just to read the code. Anything helps. Thank you.

Live in Socal? Message me and lets ride!
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Eddyg22 is offline  
Sponsored Links
Advertisement
 
post #2 of 44 Old 09-03-2019, 03:25 AM
Senior Member
 
Join Date: Mar 2018
Posts: 288
Garage
From what I recall Lightening is your man though I donít recall him being specific as to how you make the correction. But contact RapidBike.
Mirius is online now  
post #3 of 44 Old 09-03-2019, 03:27 AM Thread Starter
Senior Member
 
Eddyg22's Avatar
 
Join Date: Jan 2019
Posts: 100
Garage
(Thread Starter)
Quote:
Originally Posted by Mirius View Post
From what I recall Lightening is your man though I donít recall him being specific as to how you make the correction. But contact RapidBike.
Did you have an issue with check engine?

Live in Socal? Message me and lets ride!
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Eddyg22 is offline  
 
post #4 of 44 Old 09-03-2019, 03:29 AM
Senior Member
 
Join Date: Mar 2018
Posts: 288
Garage
I didnít but he did (I think it was him). Not sure if you both have the same module. Iíve had no issues yet with mine.
Mirius is online now  
post #5 of 44 Old 09-03-2019, 03:35 AM Thread Starter
Senior Member
 
Eddyg22's Avatar
 
Join Date: Jan 2019
Posts: 100
Garage
(Thread Starter)
Quote:
Originally Posted by Mirius View Post
I didnít but he did (I think it was him). Not sure if you both have the same module. Iíve had no issues yet with mine.
Okay. Not too sure how to contact him but I will try. Thank you.

Live in Socal? Message me and lets ride!
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Eddyg22 is offline  
post #6 of 44 Old 09-03-2019, 03:38 AM
Senior Member
 
Join Date: Mar 2018
Posts: 288
Garage
Just check his posts on the subject.
Mirius is online now  
post #7 of 44 Old 09-03-2019, 09:18 AM
Senior Member
 
pingywon's Avatar
 
Join Date: Apr 2019
Posts: 149
Garage
just wait long enough.... he'll check in here.
Eddyg22 likes this.
pingywon is offline  
post #8 of 44 Old 09-03-2019, 10:36 AM
Senior Member
 
Join Date: Mar 2018
Posts: 288
Garage
Having checked the thread I see he has an Easy which has dials on it. But others with Evo commented that they also had had check engine lights. Putting all the comments together it seems likely to me that the module plays safe and dumps in too much fuel at first and then dials it back but that initial auto tune can pull an engine light. But it goes away after tripping once or twice.

Still worth doing what Lightning did and contact dimsport instead of speculating.
Mirius is online now  
post #9 of 44 Old 09-03-2019, 11:12 AM Thread Starter
Senior Member
 
Eddyg22's Avatar
 
Join Date: Jan 2019
Posts: 100
Garage
(Thread Starter)
Quote:
Originally Posted by Mirius View Post
Having checked the thread I see he has an Easy which has dials on it. But others with Evo commented that they also had had check engine lights. Putting all the comments together it seems likely to me that the module plays safe and dumps in too much fuel at first and then dials it back but that initial auto tune can pull an engine light. But it goes away after tripping once or twice.

Still worth doing what Lightning did and contact dimsport instead of speculating.


Gotcha. I reached out yesterday to rapidbike, just waiting for a reply. Hope the light will turn off soon. Where did you find that thread at? I tried looking last night. Thanks again for your help.


Sent from my iPhone using Tapatalk

Live in Socal? Message me and lets ride!
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Eddyg22 is offline  
post #10 of 44 Old 09-03-2019, 11:28 AM
Senior Member
 
Join Date: Mar 2018
Posts: 288
Garage
I just searched for rapidbike. Turns out the thread was called something else but it can up anyway Or you can click on his profile and check his posts.
Mirius is online now  
Reply

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome