KTM Duke 390 Forum

KTM Duke 390 Forum (https://www.ktmduke390forum.com/forum/)
-   Monthly Votes (https://www.ktmduke390forum.com/forum/monthly-votes/)
-   -   DUKE stops (https://www.ktmduke390forum.com/forum/monthly-votes/19546-duke-stops.html)

Raman Maharjan 09-19-2015 05:40 AM

DUKE stops
 
after finishing my wash on bike.. after 4-5km of ride duke stops... it wont starts!! what happens?? i've no idea :(

B7ACKTHORN 09-19-2015 01:35 PM

Check your spark plugs/leads for water ingress, did you air up the parts, did you use compressed air to blow off excess water from electrical components?

What do you mean by "it won't start after 4 to 5kms" what are you trying to tell here
1) It cranks, but doesn't fire up or
2) It's completely dead?

Either way you're creamed, check for loose spark plugs/leads, water ingress and use compressed air next time you wash your bike. The bike has many exposed parts, you never know when it might short or go kaput.

Keep us posted.

Cheers!
V

Diploman 09-19-2015 07:34 PM

This is an example of why the Duke does not like to be washed with water - it gets into electrical components and creates havoc.


All times are GMT -4. The time now is 12:57 PM.

Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.

vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.

 
For the best viewing experience please update your browser to Google Chrome