KTM Duke 390 Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
539 Posts
Discussion Starter #1
So, I thought my duke has been rather chatty lately and went ahead and swapped out my tensioner (which fixed the problem and sounds great). This is a tensioner with 22,000 miles on it. That pin that has broken in a bunch of places was the only thing holding the head of my tensioner on. I imagine it wouldn't have been much longer before it completely broke allowing the rngine to skip timing and killing itself.

That pin is exactly how I removed it, I did nothing but extract it. What's interesting is the amount metal that is missing or gone all together.
51559
 

·
Registered
Joined
·
28 Posts
Helllo! What year is your model duke? And this is the cam chain tension with no cam modification?
 

·
Registered
Joined
·
539 Posts
Discussion Starter #5
Regularly serviced by the book?
Regularly service by the book. All oil changes pretty much on time with V300. 3 valve checks with no issues up until now (All completed be me). The only issue I have ever had with this bike with a leaking oil seal for my shifter shaft.
 

·
Registered
Joined
·
122 Posts
Interesting. And no guide wear, huh? No chain stretch?
Thanks for the heads up.
On the KTMWorld site, it shows the same part number for 2016 all the way thru 2019. But at least the part's only about 16.50 US.
 

·
Registered
Joined
·
539 Posts
Discussion Starter #7
Interesting. And no guide wear, huh? No chain stretch?
Thanks for the heads up.
On the KTMWorld site, it shows the same part number for 2016 all the way thru 2019. But at least the part's only about 16.50 US.

I'm going to have a look at the rest of that sometime soon. I also purchased everything for my next valve checks. The chain noise is none existent after changing out the tensioner.
 

·
Registered
Joined
·
34 Posts
Thanks for the heads up!

On a related note, when I did the valve check / adjustment, I had a heck of a time getting the top bolt out of the tensioner. It was interfering with whatever that black box is behind it. Just not enough clearance. I finally persuaded it to come out, but I was wondering if anyone else had that issue?

Cheers!
Craig
 
1 - 11 of 11 Posts
Top