KTM Duke 390 Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
17 Posts
Discussion Starter · #1 ·
Hi guys,
After a bit of advise please
I posted a while ago about having the high temp warning come on sometimes during stop start traffic
My bike runs 1 bar from the H line normally and now it’s getting hotter here during idling at traffic lights I’ll get the high temp warning fan then comes on and temp goes down, yesterday tho it did go all the way to the top line, bike didn’t cut out or anything, making me a little nervous again
I still feel my fan comes on a little late
My question after doing some research is I’ve ordered some engine ice to try that and read about the spal fan being a good upgrade due to the shroud on the OEM fan but my fan has no shroud (see attached picture) will the spal fan still make a difference?
thank you
James

53645
 

·
Super Moderator
Joined
·
1,811 Posts
The SPAL fan will still make a difference as this fan is more efficient.
It will cool down the temperature quicker but will start operating at the same temp as the Kinetic fan and shut off at the same temp.
Before filling off with engine-ice flush the cooling system thoroughly with distilled water and a bit of white vinegar.
 

·
Registered
Joined
·
17 Posts
Discussion Starter · #3 ·
The SPAL fan will still make a difference as this fan is more efficient.
It will cool down the temperature quicker but will start operating at the same temp as the Kinetic fan and shut off at the same temp.
Before filling off with engine-ice flush the cooling system thoroughly with distilled water and a bit of white vinegar.
 

·
Registered
Joined
·
17 Posts
Discussion Starter · #4 ·
Thank you for the reply masean
I have flushed the system threw will distilled water, no vinegar tho will that still be ok?
ive read threw the spalfan threads and a lot of the links to buy them are dead links now
Can you point me in the direction of the one I need, as looking on eBay there are a lot of options push/pull and sizes, I’m in the uk as well
Thank you
James
 

·
Registered
Joined
·
152 Posts

·
Registered
Joined
·
22 Posts
As a note, with my 2018, my fan comes on with about 4 bars on the temp gauge. It seems to come on quite soon. I'd suggest that maybe your fan is coming on way too late - maybe the coolant temp sensor is faulty and is giving bad readings. I don't know on these bikes if there are 2 coolant temp sensors? Some bikes have 2 - one for the fan and one for the ECU - if so, the one for the fan might be faulty?
 

·
Super Moderator
Joined
·
1,811 Posts
There is but one temperature sensor.
If the engine doesn't shut off by itself it doesn't run too hot.

As a note, with my 2018, my fan comes on with about 4 bars on the temp gauge. It seems to come on quite soon. I'd suggest that maybe your fan is coming on way too late - maybe the coolant temp sensor is faulty and is giving bad readings. I don't know on these bikes if there are 2 coolant temp sensors? Some bikes have 2 - one for the fan and one for the ECU - if so, the one for the fan might be faulty?
 
1 - 9 of 9 Posts
Top