KTM Duke 390 Forum banner

21 - 40 of 45 Posts

·
Registered
Joined
·
122 Posts
I'm having a hard time believing nobody had a comeback for that 'size isn't an issue' remark. No, really.



also, Dude, my eyes hurt!!... because i just can't stop repeating that video! Are they really that bright to the cars around you?
 

·
Registered
Joined
·
44 Posts
Discussion Starter #22
They are surprisingly bright for how small they are, but at $45 each I would hope they are.


I'm having a hard time believing nobody had a comeback for that 'size isn't an issue' remark. No, really.



also, Dude, my eyes hurt!!... because i just can't stop repeating that video! Are they really that bright to the cars around you?
 

·
Super Moderator
Joined
·
1,045 Posts
Ede,

Yet some other things might surprise you such ar footrests without rubber and exhausts (aftermarket and not necessarily loud) without the Gov's approval stamp on them.

Just out of interest, are these legal where you live? If not, what kind of fine would you expect?

Just to make it clear, personally I don't care if it's legal. I live in Bangkok and nobody here cares about little issues like that.
 

·
Registered
Joined
·
342 Posts
Ede,

Yet some other things might surprise you such ar footrests without rubber and exhausts (aftermarket and not necessarily loud) without the Gov's approval stamp on them.
In my experience all those little issues disappear with 100THB or 200THB donation to the boys in brown in Bangkok. ;)
 

·
Registered
Joined
·
122 Posts
Uh... OK... I'm revisiting this situation that damonhimself originally brought up... [about the 2017-2019 D390s]


annnnd I'm repurposing some pictures that Ede had already posted back in 7-23-2018 [when he was trying to help duke200 out of a situation].


I suppose it is also relevant because I am now in the process of converting my own 2019 US D390 to LED turn signals... so here goes.


Back in 01-17-2016, Fasteddy posted the following in the rc390-forum:


From the KTM parts finder, I have posted on another thread or two...

90511030000 FLASHER RELAY
( LED 3 wire version)

90511530000
FLASHER FOR BULB TYPE BLINKER
(2 wire version) Like the description says, this is what is on North American models



After doing a picture and fiche search on the 90511030000, I agree with his suggestion it is an LED 3 wire version for the Dukes, and here is the interesting part...


I just pulled my 2 wire version out of its holder and the 'main' harness of the 2019 US model is built to accommodate the 3-wire LED relay, just like Ede's Bangkok model,

but then mine incorporates a 3-to-2 wire short harness, as an extension, going to a 90511530000 relay instead. Hmmm...


Soooo.. What that means is... I can just ditch the 2-pin relay, and the jumper harness, and then the main harness will plug str8 into a 90511030000 factory LED relay. Wow, OK.


True, the connectors on my EU replicas (see picture) won't match up,


but I can either splice on the Rizoma EE114H adapters from whoever... [google 'EE114H' and look at the pictures, you'll see what I mean],


or I can just splice the original turn signal ends, as short harnesses, onto my new turn signals and call it a day.


As usual, you'll hafta look at the picture 'captions' to make sure you're on track with my demented thoughts. Also, zoom in on the extension cable picture so you can see they left the black/yellow wire out of the center cavity of the 3-pin cable end...


But, as I said, that black/yellow cable is very definitely in evidence on the 2019 3-pin main harness! My harness looks 'exactly' like Ede's does in the picture of his relay... and the blue end on that 2019 gender/extension cable also looks 'identical' to the blue receiver/connector of the LED relay. Get it?


Ok, thatz enuffa me.
 

Attachments

·
Registered
Joined
·
44 Posts
Discussion Starter #27
Nice! I went the fast and dirty route and just soldered everything.
 

·
Registered
Joined
·
122 Posts
And I am... officially Eurodized.

Quick Notes(?):

Until I swapped in the 3-pin LED turn relay I told you about, the turn indicator symbol in the instrument cluster did not 'blink', it just stayed on solid whenever the turn signals were on.

These particular turn signals never really 'hyper-blinked' (b4 I swapped out the relay)... well, not exactly. I'd say they blinked 150% as fast, no more than that.

I also like the fact that the manufacturer 'offset' the position of the circuit boards incorporated into the harnesses. These signals are only sold as 'pairs' and, as you can see from one of the attached pics, the supplied leads are long enough to span the entire length of the OE tag hanger (on the off-chance you're not using a Tail Tidy).

Also, I didn't see any need to have the fronts hanging out as far as the levers... But if someone 'wanted' them to, I can tell you, the circuit boards on these units will not fit thru the bores of the stock extension bolts (see pic 3). In that case, they'd hafta cut, feed, then resolder the wires back together b4 installing these particular turn signals to the Duke.

But hey, they work gr8. And like KTMasean says, 'As long as you are happy with what you ride. ;)'
 

Attachments

·
Super Moderator
Joined
·
1,045 Posts
Thanks for the quote ;)
To make your post totally correct, you are now de-North Americaned.
Because as far as I am aware of, that is the only place not using LED turn-indicators

And I am... officially Eurodized.

Quick Notes(?):

Until I swapped in the 3-pin LED turn relay I told you about, the turn indicator symbol in the instrument cluster did not 'blink', it just stayed on solid whenever the turn signals were on.

These particular turn signals never really 'hyper-blinked' (b4 I swapped out the relay)... well, not exactly. I'd say they blinked 150% as fast, no more than that.

I also like the fact that the manufacturer 'offset' the position of the circuit boards incorporated into the harnesses. These signals are only sold as 'pairs' and, as you can see from one of the attached pics, the supplied leads are long enough to span the entire length of the OE tag hanger (on the off-chance you're not using a Tail Tidy).

Also, I didn't see any need to have the fronts hanging out as far as the levers... But if someone 'wanted' them to, I can tell you, the circuit boards on these units will not fit thru the bores of the stock extension bolts (see pic 3). In that case, they'd hafta cut, feed, then resolder the wires back together b4 installing these particular turn signals to the Duke.

But hey, they work gr8. And like KTMasean says, 'As long as you are happy with what you ride. ;)'
 

·
Registered
Joined
·
329 Posts
And I am... officially Eurodized.

...
But hey, they work gr8. And like KTMasean says, 'As long as you are happy with what you ride. ;)'
For the dumb people here, could you make a list of parts you bought?



I can see the part number for the LED relay, and it looks like a straight plug-in into a US harness.


What about the flashers themselves? Also plug and play? what's the part number?


Thank you!
 

·
Registered
Joined
·
122 Posts
Ok, varroa, so you already know the number for the LED turn relay...


As for the turn signals, click this link:


https://www.ebay.com/itm/Turn-Signals-Light-Fits-KTM-125-200-250-390-690-790-Duke-RC-200-390-2010-2019-YG/312674589273?ssPageName=STRK:MEBIDX:IT&_trksid=p2060353.m2749.l2649


There are many suppliers on Ebay for this model, currently; so if you don't find it at one, you'll find it at another. They'll set you back about $65 total for two pairs.


But look at the connector in the attached picture and you'll see it's not a direct plug-n-play; they've got that old F-style connector.


So you've got two options:


1) cut the connector ends off the OE turn signals, a couple of inches back, and splice them onto these new turn signals... or
2) splice Rizoma EE114H (Revzilla #1277855 ) harness adapters onto these new turn signals; you'll need 2 packs because they come as pairs, $16 each pack.


Here's a working link to option 2:


https://www.revzilla.com/motorcycle/rizoma-turn-signal-cable-kit-ktm-390-duke-rc390


If you elect to go with option 2, I can tell you this: the Rizoma leads are about 5-6 inches long and have female bullet-style connectors at the opposite end, insulated by clear silicone boots. The main ends (that fit into the OE Duke harness) aren't plastic, they're actually a tough molded rubber that has the same [shape and notches] as the factory turn signal harness end.


And if/when you click on the Revzilla link, disregard the 'picture' showing on the page (it's not a picture of an EE114H), and disregard verifying it 'fits' (that'll mislead you too). I actually ordered and used these EE114Hs, so I can attest they do fit the 2019 OE harness (and create a positive seal).


uhhhh.... we good?
 

Attachments

·
Registered
Joined
·
321 Posts
Well done!!
What was the cost of the flasher from Ktm Georgia?
So for roughly 100$ plus the flasher relay cost and some fun time in the garage you have some LED signal lights, that look like they belong.

I know our headlights and taillights are LED already, so is that why you desired the directionals to be LED’s also? Otherwise, what was gained?
I drive for a living and pay attention to all vehicles and their details like bulbs out, tire pressures, license plates, body damage, behavioral habits while operating their vehicle, etc. so when I see KTMs that have directionals like the Duke has they seem plenty bright to me, so........ why? Just wondering.

And nevertheless, very well done in doing it right. Anything less is just a hack
 

·
Registered
Joined
·
122 Posts
I know our headlights and taillights are LED already, so is that why you desired the directionals to be LED’s also? Otherwise, what was gained? so........ why? Just wondering.

Quite seriously... I just prefer the euro led aesthetics (for myself). I always have; ever since the first time I saw them.


For instance, I also thot Damon's leds were pretty cool because, at the front, it gave the Duke a kind of rugged 'Brahma' appearance...


and at the back, it really helped clean it up (so you're not so worried about kick-boxin' a turn signal off by accident). Oh zhit, I've dun that.


See what I mean?


Then again, I know guys who didn't think my first real girlfriend was hot... but that didn't bother me because, DUDE, she really was!!!


At least, to me.;)



[can I say that on TV?]
 

·
Registered
Joined
·
44 Posts
Discussion Starter #36
I kicked off the rear right twice when I was OEM. Alway fun taking to 2 minutes to fix it when you are already late to work. LOL
 

·
Registered
Joined
·
9 Posts
Ok, varroa, so you already know the number for the LED turn relay...


As for the turn signals, click this link:


https://www.ebay.com/itm/Turn-Signals-Light-Fits-KTM-125-200-250-390-690-790-Duke-RC-200-390-2010-2019-YG/312674589273?ssPageName=STRK:MEBIDX:IT&_trksid=p2060353.m2749.l2649


There are many suppliers on Ebay for this model, currently; so if you don't find it at one, you'll find it at another. They'll set you back about $65 total for two pairs.


But look at the connector in the attached picture and you'll see it's not a direct plug-n-play; they've got that old F-style connector.


So you've got two options:


1) cut the connector ends off the OE turn signals, a couple of inches back, and splice them onto these new turn signals... or
2) splice Rizoma EE114H (Revzilla #1277855 ) harness adapters onto these new turn signals; you'll need 2 packs because they come as pairs, $16 each pack.


Here's a working link to option 2:


Rizoma Turn Signal Cable Kit KTM 390 Duke / RC390 - RevZilla


If you elect to go with option 2, I can tell you this: the Rizoma leads are about 5-6 inches long and have female bullet-style connectors at the opposite end, insulated by clear silicone boots. The main ends (that fit into the OE Duke harness) aren't plastic, they're actually a tough molded rubber that has the same [shape and notches] as the factory turn signal harness end.


And if/when you click on the Revzilla link, disregard the 'picture' showing on the page (it's not a picture of an EE114H), and disregard verifying it 'fits' (that'll mislead you too). I actually ordered and used these EE114Hs, so I can attest they do fit the 2019 OE harness (and create a positive seal).


uhhhh.... we good?
Thanks for the detailed instructions on the install of the turn signals. I tried to install the turn signals front and rear to my 2019 Duke 390. I picked up the bike new about a month ago. I had some issues and was hoping you may be able to give some guidance. I’m not the best with electrical stuff. Some background information may help.
I followed the instructions in the post and bought the relay. I installed the front turn signals first without the relay or installing the rear. I had the new eBay front turn signals on the bike for about a week and everything worked fine. New front turn signals blinked consistently and blinking on the TFT screen was fine as well. I did notice a very slight quicker blink in those front turn signals, but nothing seemed out of the ordinary. I Was also using a vagabond motorsports tail kit with the stock turn signals in the rear as well.

Today I installed my second pair of LED eBay turn signals in the rear and spliced the stock connectors on to those wires. FYI, I also spliced the front in the same manner. I noticed when I turned on the bike that I had that same issue of my TFT screen turn signal light being solid when I turned on the turn signal and the quicker flash on the turn signal as well as you stated. When I went to install the relay, I had a different result. The signal on the TFT screen was still on all the time and the turn signal was now blinking at an extremely rapid rate. I spent about an hour checking everything over and couldn’t figure out what the issue was/is. I’ve included some pictures of my install to show that I believe I did everything correct. I am at a loss for what to do now. I’m sure I could reinstall the stock rear turn signal lights back onto my tail kit and everything would work fine as it did before, but I would really like to have the same look as the front turn signals that I’m using.
Thank you,
51198
51199
51200
51201
51202
 

·
Registered
Joined
·
51 Posts
Thanks for the detailed instructions on the install of the turn signals. I tried to install the turn signals front and rear to my 2019 Duke 390. I picked up the bike new about a month ago. I had some issues and was hoping you may be able to give some guidance. I’m not the best with electrical stuff. Some background information may help.
I followed the instructions in the post and bought the relay. I installed the front turn signals first without the relay or installing the rear. I had the new eBay front turn signals on the bike for about a week and everything worked fine. New front turn signals blinked consistently and blinking on the TFT screen was fine as well. I did notice a very slight quicker blink in those front turn signals, but nothing seemed out of the ordinary. I Was also using a vagabond motorsports tail kit with the stock turn signals in the rear as well.

Today I installed my second pair of LED eBay turn signals in the rear and spliced the stock connectors on to those wires. FYI, I also spliced the front in the same manner. I noticed when I turned on the bike that I had that same issue of my TFT screen turn signal light being solid when I turned on the turn signal and the quicker flash on the turn signal as well as you stated. When I went to install the relay, I had a different result. The signal on the TFT screen was still on all the time and the turn signal was now blinking at an extremely rapid rate. I spent about an hour checking everything over and couldn’t figure out what the issue was/is. I’ve included some pictures of my install to show that I believe I did everything correct. I am at a loss for what to do now. I’m sure I could reinstall the stock rear turn signal lights back onto my tail kit and everything would work fine as it did before, but I would really like to have the same look as the front turn signals that I’m using.
Thank you, View attachment 51198 View attachment 51199 View attachment 51200 View attachment 51201 View attachment 51202
Hello, I am planning to do the same mod. Are you still experiencing these complications?
 

·
Registered
Joined
·
9 Posts
Hello, I am planning to do the same mod. Are you still experiencing these complications?
Yes. Not sure what the issue is. Was hoping someone would have experience with this on the forum. Like I stated in the response above, everything worked fine when I just changed out the front turn signals, but when I went to change out the back and added the relay I got the extremely rapid blink for all the turn signals front and rear. Maybe you will have a different experience?
 

·
Registered
Joined
·
51 Posts
Yes. Not sure what the issue is. Was hoping someone would have experience with this on the forum. Like I stated in the response above, everything worked fine when I just changed out the front turn signals, but when I went to change out the back and added the relay I got the extremely rapid blink for all the turn signals front and rear. Maybe you will have a different experience?
Let's see, I just ordered everything I need today (2 pair of turn signals from ebay the ones that cost 35 or so a pair and the 3 pronged relay). I will post back next week and let you know. Maybe your relay if faulty? Also as dukeof7 mentioned the new LEDs from eBay seem to come with a circuit board incorporated into the cables. Did you cut that board off when you spliced in your OEM connectors?
 
21 - 40 of 45 Posts
Top