KTM Duke 390 Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hi,
So I had bought a used duke 390 2015 model, but it turned out to have way too many problems. It was a impulsive buy, but I thought I will get all problems sorted out. When I took the bike on the highway I found it vibrates way too much at high speeds and the bike doesn't have much power past 100kph and maxes out at 130kph. The ktm service people say there's no problem with the bike so gave it to a 3rd party. He got the engine top end redone, but the bike still doesn't go past 130. Any idea on what the problem might be?
 

·
Registered
Joined
·
875 Posts
First off check your chain and sprockets, if the sprocket setup is altered or a chain that is kinked can make the bike vibrate at speeds, the bike would accelerate faster but would lose out of top end, that's one. Secondly, make sure air filter, fuel filter and fuel pump are at their peak. A blocked AF, FF can reduce performance dramatically. Make sure you perform a compression check to make sure there isn't excess compression loss.

Do let us know how it unfolds. Good luck.
 

·
Registered
Joined
·
461 Posts
Check the teeth on the sprockets, stock should be 15T in the front and 45T in the rear (stamped into the sprockets somewhere). If the front has less or the rear has more than that (or both), you will lose top speed. My 2015 I have the stock rear and a +1 - 16T front & have seen 112-114 mph (180-183 kph) in a tuck.
 
1 - 3 of 3 Posts
Top