KTM Duke 390 Forum banner

21 - 34 of 34 Posts

·
Registered
Joined
·
751 Posts
Discussion Starter #21
I re- installed it with the fuelling adjustment turned down from +2 to +1

The engine light never re-appeared and the unit still worked to make the bike smoother at lower RPM

However when l came to tell my insurance they refused to cover the bike at all with it fitted, so l had to disconnect it again

So l am now back with a bike that runs less smooth in traffic, although it has improved with more miles on it.
 

·
Registered
Joined
·
104 Posts

·
Registered
Joined
·
1 Posts
I've just connected a RB Easy and the same issue with the engine light has come up. The sales rep tells me that it may go away after a few rides and if it doesn't the unit will need adjustment from +2 to +1.
 

·
Registered
Joined
·
567 Posts
I've just connected a RB Easy and the same issue with the engine light has come up. The sales rep tells me that it may go away after a few rides and if it doesn't the unit will need adjustment from +2 to +1.
Lots of posts on this if you search. Short answer is yes.
 

·
Registered
Joined
·
68 Posts
After a lot of communication with the local RB agents regarding my RBE fitted to the 390 Duke and getting the engine light on I was requested by them to put the unit on 6 and +2. After riding the bike about 25km the engine light went out. I have now done 800km and the light stayed off. However I feel that a plaster has been placed on the wound.... The setting 6 on the O2 sensor side is obvious for a bike with that sensor range which the Duke may not be... but this keeps the light off. The original settings as suggested by the instruction manual had the bike pull better and smoother. At this stage I am not satisfied with RB as they need to sort out their product for the 390 Duke....
 

·
Registered
Joined
·
418 Posts
It’s been so long since my installation so I forgot the factory settings. Leave the left dial as instructions say. Right dial (fuel) from +2 to +1. That is all that needs to take place for a happy bike. I may have right and left mixed up too. Sorry. Only the fuel needs moved is what I am trying to say
 

·
Registered
Joined
·
418 Posts
Yes. Does not smell as excessively rich at the exhaust pipe either
 

·
Registered
Joined
·
290 Posts
The check engine light has gone off now, l disconnected the RBE and on the third ride after that (two yesterday and one today) the light disappeared.
Sadly this means the bike is no longer so smooth at low RPM.
I’ve emailed the RBE supplier to ask their advice.
Read ALL of the thread below......


then throw your RBE in the bin.....
 

·
Registered
Joined
·
751 Posts
Discussion Starter #31
There was an update after my above comment, which is from last year.

Dimsport, who make the RBE, were very helpful and advised me to adjust the RBE fuelling control from +2 to +1.
After l did this the unit still worked (bike is MUCH smoother at low RPM) but the “check engine” light never came on again.

All l need to do now, is find an insurance company who don’t list it as a “power commander” thus increasing my premium from £85 to £240.
After that l can refit the unit !!
 

·
Registered
Joined
·
43 Posts
BUMP :)
I just fitted the Rapid Bike Easy to my 2020 390 Duke and second ride the CEL has come on. Checked all connections, turned it back to +1 and went for a ride but its still on so put it back to +2.

Anyone found a fix for this yet or do we just ride it for a few days and PRAY that our $299 purchase comes good or has to go in the parts bin?

If this is normal then Rapid Bike Easy is one half baked item and I really hope we didnt just dump $300 bucks into it just to have to be removed again as riding around with the Engine light on is not something I want to do period...
 

·
Registered
Joined
·
418 Posts
I think I paid 200 for the RBeasy.
anyhow do the ecu relearn and then the check engine light will go off after you have performed it and the key has been cycled a couple times by riding the bike

also put it back to +1. You will still reap the benefits
 
21 - 34 of 34 Posts
Top