KTM Duke 390 Forum banner

1 - 13 of 13 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
I recently started having false neutrals as soon as I shift between 3rd to 4th, and sometimes between 4th to 5th. They are not very frequent, but happen when shifting on high revs, once every 50km of riding or so.

But worst of all, just recently I had upshifted normally without false, then a few seconds later while accelerating (and taking a bend) the false neutral kicked in by itself for a moment then kicked back in and I had to maneuver under stress to get my duke back under my control.

I spoke to the mechanic and he should be checking it, but I would like to understand what the **** is happening within the engine. I know theres a star which sets the right positioning of the gear dogs which could be faulty, but I know there are many more parts involved which could be the culprit here. Thanks!
 

·
Registered
Joined
·
98 Posts
This thing happened to me too few times - after hard accleleration in 4th gear
 

·
Registered
Joined
·
10 Posts
Discussion Starter #5
If not mistaken there is a fix from Rottweiler. Some Dukes/RC's seem to have this problem.
Cool! I will look into this, but I feel that since my bike is still under warranty, that KTM should be responsible for fixing this situation for me, without added parts... Right? If they don't manage I will get this and hope for the best.
 

·
Registered
Joined
·
21 Posts
Got the exact same issue under hard acceleration......... 3>4th and 4>5th.......happens quite regularly but as mine is 67plate it is out of warranty! Did you discover what the issue was?
 

·
Super Moderator
Joined
·
1,156 Posts
Hi SteVas,

Any update on your shift issue?
Did your dealer deal with it satisfactory and if so do you know what solved it?

Cool! I will look into this, but I feel that since my bike is still under warranty, that KTM should be responsible for fixing this situation for me, without added parts... Right? If they don't manage I will get this and hope for the best.
 

·
Registered
Joined
·
103 Posts
Do you guys get this problem with clutchless upshifting or normal shifting with the clutch?
 

·
Registered
Joined
·
10 Posts
Discussion Starter #13
Hi SteVas,

Any update on your shift issue?
Did your dealer deal with it satisfactory and if so do you know what solved it?
I had an adjustment made to the gear shifter, which reduced the frequency but it happens anyway and the shifter feels a bit off.

It's in the shop again right now, hopefully we'll get to the bottom of it this time.
 
1 - 13 of 13 Posts
Top