KTM Duke 390 Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter · #1 ·
During the First Florida "Winter" with the 2020 Duke I began receiving an interesting noise after cold starts; a Kazoo like noise. Granted I did an oil change to suit colder weather, and swapped for a K&N filter (which I am still skeptical about for small [lean-running] engines).

Well come spring it still happens on 60% of cold starts. It is strangely less likely to happen if the bike is leaning more to the right rather than straight up.

Fitted rapid bike evo 2 months ago to increase the fuel in the AFR but no change.

Even on a call with the dealership I purchased from the issue was a head-scratcher for them.

Basically it is sucking too much air in upon start up, closing, and releasing it back the way it came.
 

·
Registered
Joined
·
482 Posts
Maybe post a video?

I wouldn't install a K&N filter on this motorcycle. Already very lean, K&N probably allows way too much air. Try installing the stock filter back.
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #3 ·
Update: Installed a fresh OEM filter and cleaned the airbox. Issue occurs less often but I did find oil in the air box as well.
 

·
Super Moderator
Joined
·
1,626 Posts
A higher flow air filter is okay with an RB EVO.
I've been running DNA filters in both my 200 and 390 with a PT and RBEVO without any issues whatsoever for a combined # of kilometres around 60,000+

Maybe post a video?

I wouldn't install a K&N filter on this motorcycle. Already very lean, K&N probably allows way too much air. Try installing the stock filter back.
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #5 ·
After taking to the service department manager who is a 6'7" man that rides a grom religiously, I have realized I need to find a new shop to evaluate the bike.
 
1 - 5 of 5 Posts
Top