KTM Duke 390 Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
My 2017 390 duke's high beam doesn't work and the entire headlight cuts out periodically.
I bought a 2017 390 duke with only 1000kms on it and I have noticed that when I turn on the high beam, nothing happens other then the low beam gets duller. So turning the high beam on actually makes the light duller overall. The lower bank of lights (high beam LEDs) never turn on even with the high beam switch turned on. Also, I have noticed that the low beams cut out periodically which is quite dangerous at night as you could imagine.
With such low kms on the bike, I'm gathering, this was an issue from new.
Has anyone had a similar experience? or know of how to fix this?
Thanks.
 

·
Super Moderator
Joined
·
1,692 Posts
If not mistaken, this (or similar) issue was addressed before on the forum
If my memory serves me well it was a matter of a software update.
Pls check what software you are running and ask your dealer what their latest is.
Good luck.
 

·
Registered
Joined
·
463 Posts
The headlight has not "normal" inputs for low beam and high beam. It has a CAN-Bus input which is something for electronic engineers. You can see that on the wiring diagram which is available in this forum.

I think basically the only think you can do yourself is to check the connector. Maybe it is lose.
Otherwise you need the specialists from KTM. I am pretty sure they will have a special electronic tool to check your light. Without such tool or a computer and detailed CAN-Bus knowledge you have no chance to analyze this further.
 
1 - 3 of 3 Posts
Top