KTM Duke 390 Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Hello everyone,
My 2017 Duke 390 broke down the other day. Was ok on the way to work and after my shift when ive started it up the light went off and ive got two messages on the screen first being HLU failure and second ABS failure.
Real nighmare if all you want to do is rush home after work...
I had a bit of a look around checking the fuses, battery, disconnected the alarm (my proximity sensor is a bit iffy at times) took the headlight off looking for broken wires etc.
Gave the abs sensor a clean and i had it running twice without the errors but never being sure enough third start and it went back to the faults.
We are at a point where he doesnt cut out idling now and after a couple of seconds the light comes back on again still with faults unfortunately.
Cuts out as soon as you try to move off.
Any ideas where to look? Lockdown not a joke and the closest KTM garage will maybe reopen in May and give me a ring to check if im still in need of their services, tried ot find a mobile mechanic to come out (bike stuck at work) but get same response from most - ' im not good with KTMs'.
Havnt looked at the other ABS fuses yet. Would you say it could be a busted relay?
Any suggestions will help as i need the bike to get to work - not best times to use public transport.
Video link below.
Cheers and all the best!

HLU failure & ABS Failure
 

·
Registered
Joined
·
3 Posts
Hello everyone,
My 2017 Duke 390 broke down the other day. Was ok on the way to work and after my shift when ive started it up the light went off and ive got two messages on the screen first being HLU failure and second ABS failure.
Real nighmare if all you want to do is rush home after work...
I had a bit of a look around checking the fuses, battery, disconnected the alarm (my proximity sensor is a bit iffy at times) took the headlight off looking for broken wires etc.
Gave the abs sensor a clean and i had it running twice without the errors but never being sure enough third start and it went back to the faults.
We are at a point where he doesnt cut out idling now and after a couple of seconds the light comes back on again still with faults unfortunately.
Cuts out as soon as you try to move off.
Any ideas where to look? Lockdown not a joke and the closest KTM garage will maybe reopen in May and give me a ring to check if im still in need of their services, tried ot find a mobile mechanic to come out (bike stuck at work) but get same response from most - ' im not good with KTMs'.
Havnt looked at the other ABS fuses yet. Would you say it could be a busted relay?
Any suggestions will help as i need the bike to get to work - not best times to use public transport.
Video link below.
Cheers and all the best!

HLU failure & ABS Failure
Bro i have same problem like you
 

·
Registered
Joined
·
3 Posts
Hi Guys,
I have an 2015 RC390, and it has been flooded in 2018. I had the battery removed before its been flooded. After the flood, i had the bike cleaned of water, drained the oil, Sun Dried most of the parts. The instrument console was acting weird for few days, then it was fine. Since then everything worked fine, except the ABS and Speedometer. The ABS light stays on and there is not speedometer. The KTM Service center guys have no idea and asked me to change the ABS Module. Any Idea what is causing this? Im pretty sure the ABS module is water proof just like the ECU.
 
1 - 8 of 8 Posts
Top