KTM Duke 390 Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
518 Posts
Discussion Starter · #1 ·
I just found a 390 adventure one year used for just 5000 euros, so I bought it. Great bike, tried some fire roads also reminded me my old klx300, only a little bit... stronger and heavier

Some times makes a stall like someone unplugs the wire for a second, or like a fuel cut for a second. Checked the plug wiring, is not loose. Read some forums said they fixed this (at duke) by cleaning the throttle and the fuel filters.

Bike is still on warranty.

Any help?

Sent from my A80Pro using Tapatalk
 

·
Super Moderator
Joined
·
1,866 Posts
Congrats, you'll miss the 200 ;)
Is it the same system as on the other 390s with the side stand switch?
Perhaps this is where your issue lays?
 

·
Registered
Joined
·
518 Posts
Discussion Starter · #3 ·
Thank you for your answer, fortunately that wasn't the issue. Thank God it was just bad fuel that maybe had affected the injector. I just added some injector cleaner and 100 Ron fuel and after a couple of miles no more engine cut.

I will definitely miss the agility and sharp cornering of my little duke. Fortunately it will go to a good friend of mine, so it will stay close.

Sent from my A80Pro using Tapatalk
 

·
Registered
Joined
·
11 Posts
If you're going to go off-road, make sure that you turn the ABS/traction control off: left on, it will cut the throttle at the most inopportune times!
 

·
Registered
Joined
·
518 Posts
Discussion Starter · #6 ·
You are absolutely right. It's like fuel cutting.....

Sent from my A80Pro using Tapatalk
 

·
Registered
Joined
·
11 Posts
It sure does but, in my case, the dumb operator didn't turn it off. My staff calls it an "eye dee ten-tee" error: say it out loud, write it down, and you'll understand the problem.
 
1 - 8 of 8 Posts
Top