KTM Duke 390 Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
119 Posts
Discussion Starter · #1 ·
Tonight was the first time I've rode my duke in the dark since nice had it and when getting on it I thought the main beam was rubbish so dealt with it for around nine miles. When I got to where I was going the light suddenly sparked into life and was much better. I turned the bars a few times and the light flickered. It is most certainly a loose/bad connection somewhere, I can tell this by the nature of the fault but I can't see anything obvious on having a quick look. If it makes any difference I have the headlight mask kit fitted to my bike. Has anyone else experienced this?

Thanks is advance
 

·
Registered
Joined
·
533 Posts
hey Mos is the mask just a fit on top mask or like the 125, a full lamp replacement?



if its the latter, I would say it definitely has something to do with the mask as the whole assembly would of been removed and replaced. If not disregard my mumbling :D
 

·
Registered
Joined
·
264 Posts
Tonight was the first time I've rode my duke in the dark since nice had it and when getting on it I thought the main beam was rubbish so dealt with it for around nine miles. When I got to where I was going the light suddenly sparked into life and was much better. I turned the bars a few times and the light flickered. It is most certainly a loose/bad connection somewhere, I can tell this by the nature of the fault but I can't see anything obvious on having a quick look. If it makes any difference I have the headlight mask kit fitted to my bike. Has anyone else experienced this?

Thanks is advance
No but the wiring under the headlight shroud was a real rats nest. I'm not surprised this has happened - a connector is being tugged when you're turning the bars.
 

·
Registered
Joined
·
119 Posts
Discussion Starter · #4 ·
hey Mos is the mask just a fit on top mask or like the 125, a full lamp replacement?



if its the latter, I would say it definitely has something to do with the mask as the whole assembly would of been removed and replaced. If not disregard my mumbling :D
Hi mate, yes it's the whole lamp replacement. It's the same unit as shown in your pic. I'll check it out later on when I get chance. Hopefully not too much of a job.
 

·
Registered
Joined
·
533 Posts
No but the wiring under the headlight shroud was a real rats nest. I'm not surprised this has happened - a connector is being tugged when you're turning the bars.
is there excess wire wound up in there as well? Wondering if you could just let out a little more slack and it would be ok?
 

·
Registered
Joined
·
264 Posts
is there excess wire wound up in there as well? Wondering if you could just let out a little more slack and it would be ok?

Not wound up - just badly laid out and arranged it seems if mine is the typical example. Lots of criss crosses where tensions can occur. Pull it all free, lay it in nicely and logically while moving the bars around and you'll see what the issue is.
 
1 - 9 of 9 Posts
Top