KTM Duke 390 Forum banner
1 - 15 of 15 Posts

·
Administrator
Joined
·
184 Posts
Discussion Starter · #1 ·
Hi all - use this section to discuss the KTM 390 and anything tech. Mods you want to make, questions on specs, and so forth.

Enjoy!
 

·
Registered
Joined
·
3 Posts
I've recently bought a 390 Duke.

It runs and handles great, the problem is starting - first it wouldn't start when warm, so back to the garage and fixed - something wrong with the KTM valve settings that were issued!!

Now it won't start at all - so back to the garage tomorrow!

It is very frustrating - has anyone else had problems with the bike starting?
 

·
Registered
Joined
·
200 Posts
I've recently bought a 390 Duke.

It runs and handles great, the problem is starting - first it wouldn't start when warm, so back to the garage and fixed - something wrong with the KTM valve settings that were issued!!

Now it won't start at all - so back to the garage tomorrow!

It is very frustrating - has anyone else had problems with the bike starting?
@Anditomo

Congrats!

That is a shame with the starting issue. I mean for a brand new bike this is not cool. Have you checked the engine kill switch? You should record a video of it trying to start.

Well keep us updated on what happens tomorrow when you bring it back to the garage. I am curious to see what the exact issue would be. Thanks.
 

·
Registered
Joined
·
1,087 Posts
I want to put a light bar on the front instead of the headlight. I can't find a picture exactly, but this is something like what I am thinking.



Anyone else planning any mods out of the gate?
That's not a bad idea, I just hate how it makes the bikes front end look. LED's in the factory headlight would be sweet! Retain the stock look and have all the light output you need = win
 

·
Registered
Joined
·
208 Posts
Part of the reason why I want to put the light bar on is for the look. Here is a picture of a Honda Grom with one installed. I'd have to figure out exactly how to do it and make it look finished, but this is the inspiration.

 

·
Registered
Joined
·
200 Posts
Part of the reason why I want to put the light bar on is for the look. Here is a picture of a Honda Grom with one installed. I'd have to figure out exactly how to do it and make it look finished, but this is the inspiration.

That thing must be super bright when turned on. I'm guessing it would blind the oncoming traffic. But it does look cool though.
 

·
Registered
Joined
·
573 Posts
i just installed a PIAA horn ... and a USB charger point ...and a spooler
below are some pics ...
 

Attachments

·
Registered
Joined
·
2 Posts
i just installed a PIAA horn ... and a USB charger point ...and a spooler
below are some pics ...
Its very nice to see these installed, on your bike one doubt i am having is that the usb charger does need a fuse or not iam going to install the usb charger in my rc390 and how you fit it whether directly to the battery or through a switch.
 

·
Registered
Joined
·
223 Posts
Naveeth

Connect it to the accessory terminal - inside the front cowling under your display. It will then run through a fuse and be switched on / off by the ignition.
 

·
Registered
Joined
·
2 Posts
Thanks GeO for helping me out

It seems these are the socket for additional accessory actually there are two of them there.First I was little confused about installing charger in my bike like does it ruin my battery by short circuiting it but now i am cleared:)
 

Attachments

·
Registered
Joined
·
19 Posts
I've recently bought a 390 Duke.

It runs and handles great, the problem is starting - first it wouldn't start when warm, so back to the garage and fixed - something wrong with the KTM valve settings that were issued!!

Now it won't start at all - so back to the garage tomorrow!

It is very frustrating - has anyone else had problems with the bike starting?
Does the starter is clicking? If yes check under the pilion seat. Next to the rubber fuse box you gonna see a big wire with a rubber cap. Make sure that wire is thithen enough. Mine had starting issue and that cable was the problem...
 

·
Registered
Joined
·
75 Posts
Starting

I am guessing that "thithen" is an attempt at tighten?


If so yes 110% loose/poor conntection earth wires are the major cause of mystery starting probs and poor battery charging>:D
 
1 - 15 of 15 Posts
Top