KTM Duke 390 Forum banner
1 - 6 of 6 Posts

· Registered
Joined
·
9 Posts
Discussion Starter · #1 ·
Hello, yesterday I dropped my bike for the first time, it was moving at about 3 km/hr so it was nothing nasty. However, once I picked it up and restarted it the engine service light started blinking : 1 x long 7x short. I have been doing some research and it says it is the Lambda Probe Malfunction. I have checked and I cannot see any evident damage to the bike or any loose wires. Any idea what this could be?

Thanks in advance
 

· Registered
Joined
·
637 Posts
I suggest you go to the dealer to see better what's the case with lambda check engine, and remember to tell them which side of the bike touched the ground. Lambda check engine comes not only from lambda sensor but almost everything has to do with fuel burn (misfire, lean mixture, IAT, TPS, MAP failure, etc). Meanwhile you can check all visible connectors for proper fitment.
 

· Registered
Joined
·
3 Posts
I suggest you go to the dealer to see better what's the case with lambda check engine, and remember to tell them which side of the bike touched the ground. Lambda check engine comes not only from lambda sensor but almost everything has to do with fuel burn (misfire, lean mixture, IAT, TPS, MAP failure, etc). Meanwhile you can check all visible connectors for proper fitment.
sir also bike same problem i crashed not too much damage on my motorcycle ktm duke 390 but until now wont start there have a power in coil and injector give gas but still cranking only
 

· Registered
Joined
·
1 Posts
Dear KTM Riders,

I'm BMG from Kuala Lumpur. I'm having a problem with my cute 390. The service engine light is blinking and the engine is off by itself when I warm up. It stays for a few minutes and it off itself. If I tried to ride, the flow was not smooth, and stuck. What could be the causes? Seek your advice.
Thank you,
 
1 - 6 of 6 Posts
Top