KTM Duke 390 Forum banner

1 - 20 of 121 Posts

·
Registered
Joined
·
327 Posts
Discussion Starter #1
Anyone else with a 2017 have moisture appear behind the plastic screen on the TFT? I live in a maritime climate and it's always very humid but the past few days have been ridiculous (above 90% humidity). I was out of town for a few days so my bike was parked in my garage with a dehumidifier going. Today I took a rip to the grocery store and on the way home noticed moisture behind the screen of the TFT. I tried to get photos but it's difficult to capture it. You can see it along the edge and on the corners. Anyone else experience this?
 

·
Premium Member
Joined
·
128 Posts
Up for service tomorrow and a recall service for light and screen. let you know it has anything to do with moisture.
 

·
Registered
Joined
·
21 Posts
The moisture in the head light unit was a recurrin
g problem earlier in the chat forums in India....but not I believe moisture in the tft screen

Sent from my VS987 using Tapatalk
 

·
Registered
Joined
·
13 Posts
I had the same issue on mine, it was just on the edge so it didn't bother me that much. I'll ask my dealer at the 650mi revision to look at it.
 

·
Registered
Joined
·
259 Posts
Mine has this and I will be getting it fixed at the first service. I think there is a serious design flaw in the displays case. Clearly they have not sealed it properly. Replacing it with the same flawed design is going to fix nothing.

If anyone has had theirs replaced already, has it reoccured?
 

·
Registered
Joined
·
34 Posts
I took the display down from bike, and when I am trying to blow around the edge of display (where is the seam), the display does not mosturize, so I think, that this sealing is OK.
But on the rear side of display, there are 4 holes (except of screw holes), and when I am blowing into them, 3 are ok, but through one hole I can blow into display, so I think, this is the problem. I am going to dry display at home for some time and then seal this hole.
 

Attachments

·
Registered
Joined
·
259 Posts
I took the display down from bike, and when I am trying to blow around the edge of display (where is the seam), the display does not mosturize, so I think, that this sealing is OK.
But on the rear side of display, there are 4 holes (except of screw holes), and when I am blowing into them, 3 are ok, but through one hole I can blow into display, so I think, this is the problem. I am going to dry display at home for some time and then seal this hole.
If you put the display in a freezer bag with some brown rice. You can seal up the bag and put it in a warmish place. The rice will absorb all the water. Works on phones too :D
 

·
Registered
Joined
·
327 Posts
Discussion Starter #12
If you put the display in a freezer bag with some brown rice. You can seal up the bag and put it in a warmish place. The rice will absorb all the water. Works on phones too :D
I'm still waiting on my dealer to respond to my issues with this TFT (and the bike in general). The inside of my screen is permanently "etched" at this point and you can see the water lines even when it is dry. I've been looking for a resolution to my issues now since my first service months and months ago but every time I contact my dealer I just get told that they are waiting for KTM to get back to them and that they will put another call into them. I'm basically getting the run around.

Trying so hard not to hate this bike but it's not easy with the combination of the problems with the bike and lack of dealer / KTM action for the issues.
 

·
Registered
Joined
·
17 Posts
I have a 15 and 16 390 and the instrument cluster got moisture in both of them. The dealer replaced them under warranty at no cost but the new clusters each have moisture in them already after only a few weeks. The dealer says that they will replace them again and has ordered the parts and will schedule the replacement when they arrive.
 

·
Registered
Joined
·
327 Posts
Discussion Starter #14
Well my dealer finally got hold of KTM Canada. They say there's software updates for the bike which should fix the TFT issues with milage resets etc. They have also said they will replace the whole TFT due to the moisture issues.... I guess they do not sell the top cover separately. I dropped the bike off at the shop today so hopefully it'll be fixed by riding season!
 

·
Registered
Joined
·
327 Posts
Discussion Starter #16
Ok. Bike is back. Brand new TFT screen installed. Tech said that the ECU mileage was showing about 200km higher than the TFT which confirms that the ODO was resetting on the TFT. I guess the TFT is literally just a display and the proper information is kept in the ECU. Also 200 km off on a bike with 1600 km is quite a bit.

Software version now is 5V39...I thought it would be in the 40's as I've seen it mentioned in the forum's.

One issue so far is that the blue background on the menu seems to be flickering a bit, and it won't pair with my phone.

Once again I fear the TFT revolution will kill the "future proofness" of motorcycles.... Gimmie an analog ODO and speedo at this point and I'd be a happy man!!
 

·
Registered
Joined
·
34 Posts
My attempt to fix this problem, by sealing hole on back of the display, didn´t work. The moisture was here again on first ride after this fix. So I really can´t understand from where is that moisture, maybe I just didn´t dried it properly... So I must probably go to the service to fix it by replacing, as others here.
 

·
Registered
Joined
·
259 Posts
My attempt to fix this problem, by sealing hole on back of the display, didn´t work. The moisture was here again on first ride after this fix. So I really can´t understand from where is that moisture, maybe I just didn´t dried it properly... So I must probably go to the service to fix it by replacing, as others here.
I suspect the way it's sealed around the whole unit is not being done properly. It must be costing KTM a fortune. You'd think they'd have changed the design already at this point.
 
1 - 20 of 121 Posts
Top